Fixes 4.6.1 compiler build with gcc 4.7 (XCC)
authorBarret Rhoden <brho@cs.berkeley.edu>
Tue, 5 Feb 2013 18:23:21 +0000 (10:23 -0800)
committerBarret Rhoden <brho@cs.berkeley.edu>
Tue, 5 Feb 2013 18:23:21 +0000 (10:23 -0800)
commite6025f30edff3a97db97ff307fc198ac77eabb24
tree1d193267b5a750c7a898748b23a0cf4149fbfbe7
parent0a19848d01420aebfefdae1685f8f3055b3d9f8a
Fixes 4.6.1 compiler build with gcc 4.7 (XCC)

Gcc 4.7 can't build 4.6.1.  Check out
http://gcc.gnu.org/bugzilla/show_bug.cgi?id=51969 for more info.

All of this takes place in tools/compilers/gcc-glibc/:

- If you want to build gcc with 4.7 and have a dirty working directory,
  rm .i686-ros-gcc-stage1-configure (or whatever) and gcc-4.6.1/, and a
  fresh 'make x86' ought to extract and patch 4.6.1's sources (and test
  the Makefile for new people).

- Alternatively, just patch (-p1) the new patch, or do a make clean.

- If you do nothing, you might have an issue in the future when your
  distro upgrades to 4.7.
tools/compilers/gcc-glibc/Makefile
tools/compilers/gcc-glibc/gcc-4.6.1-compile.patch [new file with mode: 0644]