virtio console can't support V2, have to use V1.
authorRonald G. Minnich <rminnich@gmail.com>
Wed, 12 Aug 2015 16:59:24 +0000 (09:59 -0700)
committerBarret Rhoden <brho@cs.berkeley.edu>
Mon, 2 Nov 2015 23:24:25 +0000 (18:24 -0500)
commit159b1b088af61cacf1c1c91a71c68260f95c7721
tree02b00908abba4c1d0a42f75049e52140c352ec50
parente9ae0b86336d0af535c23bc9e1f953dec5e4e16f
virtio console can't support V2, have to use V1.

But also fixed the features crap.

The features stuff is damned confusing but it boils down to
"if you support v2, you have to say you support v1. And if you support
v1 you have to accept v1."

I don't know, I still don't get it all.

Signed-off-by: Ronald G. Minnich <rminnich@gmail.com>
Signed-off-by: Barret Rhoden <brho@cs.berkeley.edu>
tests/vmm/vmrunkernel.c
user/vmm/include/virtio_mmio.h
user/vmm/virtio-mmio.c