virtio console can't support V2, have to use V1.
[akaros.git] / tests / vmm / vmrunkernel.c
index 243b1b0..86a6eeb 100644 (file)
@@ -166,7 +166,7 @@ void *consin(void *arg)
 static struct vqdev vqdev= {
 name: "console",
 dev: VIRTIO_ID_CONSOLE,
-features: VIRTIO_F_VERSION_1,
+device_features: 0, /* Can't do it: linux console device does not support it. VIRTIO_F_VERSION_1*/
 numvqs: 2,
 vqs: {
                {name: "consin", maxqnum: 2, f: &consin, arg: (void *)0},