Proc vcore list only has available vcores
[akaros.git] / kern / src / init.c
index 5a21549..1a76999 100644 (file)
 #include <blockdev.h>
 #include <ext2fs.h>
 #include <kthread.h>
-#include <net.h>
-#include <socket.h>
-#include <eth_audio.h>
 #include <console.h>
+#include <linker_func.h>
+#include <ip.h>
+#include <acpi.h>
+#include <coreboot_tables.h>
 
 // zra: flag for Ivy
 int booting = 1;
+struct sysinfo_t sysinfo;
+static void run_linker_funcs(void);
 
 void kernel_init(multiboot_info_t *mboot_info)
 {
@@ -72,6 +75,7 @@ void kernel_init(multiboot_info_t *mboot_info)
        radix_init();
        cache_color_alloc_init();       // Inits data structs
        colored_page_alloc_init();      // Allocates colors for agnostic processes
+       acpiinit();
        kthread_init();                                 /* might need to tweak when this happens */
        vmr_init();
        file_init();
@@ -86,14 +90,19 @@ void kernel_init(multiboot_info_t *mboot_info)
        arch_init();
        block_init();
        enable_irq();
-       socket_init();
+       run_linker_funcs();
+       /* reset/init devtab after linker funcs 3 and 4.  these run NIC and medium
+        * pre-inits, which need to happen before devether. */
+       devtabreset();
+       devtabinit();
+
 #ifdef CONFIG_EXT2FS
        mount_fs(&ext2_fs_type, "/dev/ramdisk", "/mnt", 0);
 #endif /* CONFIG_EXT2FS */
 #ifdef CONFIG_ETH_AUDIO
        eth_audio_init();
 #endif /* CONFIG_ETH_AUDIO */
-
+       get_coreboot_info(&sysinfo);
        // zra: let's Ivy know we're done booting
        booting = 0;
 
@@ -140,4 +149,43 @@ void _warn(const char *file, int line, const char *fmt,...)
        va_end(ap);
 }
 
+static void run_links(linker_func_t *linkstart, linker_func_t *linkend)
+{
+       /* Unlike with devtab, our linker sections for the function pointers are
+        * 8 byte aligned (4 on 32 bit) (done by the linker/compiler), so we don't
+        * have to worry about that.  */
+       printd("linkstart %p, linkend %p\n", linkstart, linkend);
+       for (int i = 0; &linkstart[i] < linkend; i++) {
+               printd("i %d, linkfunc %p\n", i, linkstart[i]);
+               linkstart[i]();
+       }
+}
+
+static void run_linker_funcs(void)
+{
+       run_links(__linkerfunc1start, __linkerfunc1end);
+       run_links(__linkerfunc2start, __linkerfunc2end);
+       run_links(__linkerfunc3start, __linkerfunc3end);
+       run_links(__linkerfunc4start, __linkerfunc4end);
+}
+
+/* You need to reference PROVIDE symbols somewhere, or they won't be included.
+ * Only really a problem for debugging. */
+void debug_linker_tables(void)
+{
+       extern struct dev __devtabstart[];
+       extern struct dev __devtabend[];
+       printk("devtab %p %p\nlink1 %p %p\nlink2 %p %p\nlink3 %p %p\nlink4 %p %p\n",
+              __devtabstart,
+              __devtabend,
+                  __linkerfunc1start,
+                  __linkerfunc1end,
+                  __linkerfunc2start,
+                  __linkerfunc2end,
+                  __linkerfunc3start,
+                  __linkerfunc3end,
+                  __linkerfunc4start,
+                  __linkerfunc4end);
+}
+
 #endif //Everything For Free