Upgrade to glibc-2.19
[akaros.git] / tools / compilers / gcc-glibc / glibc-2.19-akaros / shlib-versions
1 # This file defines the shared library version numbers we will install.
2
3 # The following lines list filename patterns matching canonical configurations,
4 # and the associated versions to use for various libraries.  The entire
5 # list is processed, with earlier entries taking precedence over later
6 # entries.  So loose patterns at the end of the list can give defaults.
7
8 # This file can use cpp-style conditionals starting with % instead of #
9 # to test the symbols defined in config.h by configure.
10
11 # In the optional third column, there can one or more symbol set names
12 # listed, which must be in ascending version order reading left to right
13 # and must appear in this same order in the Versions.def file.  Each listed
14 # version subsumes all prior versions back to the previous listed version.
15 #
16 # An entry with DEFAULT in the second column gives a default third column
17 # to apply on matching configurations when the matching entry for a particular
18 # library has no third column.  The defaults must precede the entries they
19 # apply to.
20 #
21 # Configuration         DEFAULT                 Earliest symbol set
22 # -------------         ---------------         ------------------------------
23
24 s390x-.*-linux.*        DEFAULT                 GLIBC_2.2
25 powerpc64-.*-linux.*    DEFAULT                 GLIBC_2.3
26 powerpc.*le-.*-linux.*  DEFAULT                 GLIBC_2.17
27 x86_64-.*-akaros.*      DEFAULT                 GLIBC_2.2.5
28 .*-.*-gnu-gnu.*         DEFAULT                 GLIBC_2.2.6
29
30 # Configuration         ABI                     Identifier for ABI data files
31 # -------------         ----------              -----------------------------
32 sparc64.*-.*-.*         ABI                     sparc64-@OS@
33 sparc.*-.*-.*           ABI                     sparc-@OS@
34
35 # Configuration         Library=version         Earliest symbol set (optional)
36 # -------------         ---------------         ------------------------------
37
38 # The interface to -lm depends mostly only on cpu, not on operating system.
39 sparc64.*-.*-linux.*    libm=6                  GLIBC_2.2
40 sh.*-.*-linux.*         libm=6                  GLIBC_2.2
41 .*-.*-linux.*           libm=6
42 .*-.*-gnu-gnu.*         libm=6
43
44 # We provide libc.so.6 for Linux kernel versions 2.0 and later.
45 sh.*-.*-linux.*         libc=6                  GLIBC_2.2
46 sparc64.*-.*-linux.*    libc=6                  GLIBC_2.2
47 .*-.*-linux.*           libc=6
48 .*-.*-akaros.*          libc=6
49
50 # libmachuser.so.1 corresponds to mach/*.defs as of Utah's UK22 release.
51 .*-.*-gnu-gnu.*         libmachuser=1
52
53 # libhurduser.so.0.3 corresponds to hurd/*.defs as of 11 June 2002.
54 .*-.*-gnu-gnu.*         libhurduser=0.3
55
56 # libc.so.0.3 is the first Hurd libc using libio.
57 .*-.*-gnu-gnu.*         libc=0.3
58
59 # The dynamic loader also requires different names.
60 sparc64.*-.*-linux.*    ld=ld-linux.so.2        GLIBC_2.2
61 sparc.*-.*-linux.*      ld=ld-linux.so.2
62 sh.*-.*-linux.*         ld=ld-linux.so.2        GLIBC_2.2
63 # We use the ELF ABI standard name for the default.
64 .*-.*-.*                ld=ld.so.1
65
66 # The -ldl interface (see <dlfcn.h>) is the same on all platforms.
67 .*-.*-.*                libdl=2
68
69 # So far the -lutil interface is the same on all platforms, except for the
70 # `struct utmp' format, which depends on libc.
71 .*-.*-.*                libutil=1
72
73 # Version number 2 is used on other systems for the BIND 4.9.5 resolver
74 # interface.
75 .*-.*-.*                libresolv=2
76
77 # Interface revision of nss_* modules.  This must match NSS_SHLIB_REVISION
78 # in nss/nsswitch.h, which determines the library names used for service
79 # names given in /etc/nsswitch.conf.
80 .*-.*-.*                libnss_files=2
81 .*-.*-.*                libnss_dns=2
82 .*-.*-.*                libnss_compat=2
83 .*-.*-.*                libnss_nis=2
84 .*-.*-.*                libnss_nisplus=2
85 .*-.*-.*                libnss_ldap=2
86 .*-.*-.*                libnss_hesiod=2
87 .*-.*-.*                libnss_db=2
88
89 # Tests for NSS.  They must have the same NSS_SHLIB_REVISION number as
90 # the rest.
91 .*-.*-.*                libnss_test1=2
92
93 # Version for libnsl with YP and NIS+ functions.
94 .*-.*-.*                libnsl=1
95
96 # This defines the shared library version numbers we will install.
97 .*-.*-.*                libcrypt=1
98
99 # The gross patch for programs assuming broken locale implementations.
100 sh.*-.*-.*              libBrokenLocale=1       GLIBC_2.2
101 sparc64.*-.*-.*         libBrokenLocale=1       GLIBC_2.2
102 .*-.*-.*                libBrokenLocale=1
103
104 # The real-time library from POSIX.1b.
105 .*-.*-.*                librt=1
106
107 # The asynchronous name lookup library.
108 .*-.*-.*                libanl=1
109
110 # This defines the libgcc soname version this glibc is to load for
111 # asynchronous cancellation to work correctly.
112 .*-.*-.*                libgcc_s=1